Let's Encrypt planned maintenance
Incident Report for Aptible
Resolved
This incident has been resolved.
Posted May 18, 2018 - 11:32 EDT
Monitoring
Due to Let's Encrypt's planned maintenance, new certificate issuance is currently unavailable for new Managed HTTPS Endpoints.

This does not affect Custom HTTPS Endpoint creation, or the functionality of any existing Endpoints.

https://letsencrypt.status.io/
Posted May 18, 2018 - 10:56 EDT
This incident affected: Let's Encrypt.