New Managed HTTPS domains may fail to activate
Incident Report for Aptible
Resolved
The underlying issue has been resolved by LetsEncrypt, and new Managed HTTPS Endpoint creation should work as usual again.
Posted May 19, 2017 - 22:03 EDT
Update
Let's Encrypt remains down at this time.

Note that if you'd like to set up a new Endpoint on Aptible, you can of course opt to provide a transitional certificate for now, and transition to Managed HTTPS once Let's Encrypt is back up.
Posted May 19, 2017 - 12:40 EDT
Monitoring
Let's Encrypt is having difficulties; issuance of new Managed HTTPS certificates may be delayed: https://letsencrypt.status.io/.

Existing Managed HTTPS Endpoints are not affected.
Posted May 19, 2017 - 10:33 EDT