Delayed email delivery
Incident Report for Aptible
Resolved
Customer.io indicates they're still monitoring the issue, but we're seeing near immediate delivery at the moment.
Posted 5 months ago. Apr 01, 2019 - 22:18 EDT
Identified
Our 3rd party services used to send emails (Role invitations, New user verifications, password resets, etc) are experiencing an issue causing delays in email delivery. Currently we're see emails being delayed by at least 30 minutes.

https://status.customerio.com/incidents/2td8zfd1dvgv
Posted 5 months ago. Apr 01, 2019 - 17:08 EDT
This incident affected: gridiron.aptible.com and dashboard.aptible.com.