Operation failures to to AWS API incident

Incident Report for Aptible

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 05:46 EDT

Update

AWS has indicated a fix has been applied, and we are re-enabling operations.

We will continue to monitor for additional impact, as both Dockerhub and Quay.io were offline due to the AWS issue.
Posted Oct 20, 2025 - 05:30 EDT

Monitoring

Since the AWS issues seem serious, and to avoid any operation failures causing resources to get stuck in a transitional state, we are taking action to block all new operations on the platform at this time.

We have identified no impact to acceibilty or preformance of running apps and database containers at this time.
Posted Oct 20, 2025 - 04:31 EDT

Identified

AWS is experiencing an issue with their APIs in us-east-1, and many services are impacted at this time. This may lead to failed operations, but there appears to be no impact to availability for apps and databases running on Aptible at this time.
Posted Oct 20, 2025 - 03:47 EDT
This incident affected: AWS EC2 (AWS EC2 (us-east-1 — Virginia)) and Aptible Deploy.