High operation failure rate due to EC2 API issues
Incident Report for Aptible
Resolved
As of the last status update at 20:37 UTC (4:37pm EDT), there have been no further EC2-related issues.
Posted Jul 19, 2016 - 21:24 EDT
Monitoring
After a resolution of the underlying EC2 incident, new deploy/restart/rebuild/configure operations are being processed as normal. Operations that were enqueued during the incident will have terminated (with no change to app state) and will appear as "failed" in the Aptible operation log.
Posted Jul 19, 2016 - 16:37 EDT
Identified
While we continue to debug the EC2 incident (and wait for EC2's status to stabilize), we have temporarily suspended release operations for all apps. Any deploy/restart/rebuild/configure operation will remain queued until we are confident that the underlying EC2 issue is resolved.
Posted Jul 19, 2016 - 15:20 EDT
Investigating
Due to an ongoing incident with the EC2 API, several Aptible operations (mostly around deploys of new code and app restarts) are failing. We're working to determine the root cause of this EC2 issue and identify possible workarounds. Availability of customer apps and databases should not be affected by this incident.

Please also refer to http://status.aws.amazon.com
Posted Jul 19, 2016 - 14:52 EDT