Route53 increased propagation delays

Incident Report for Aptible

Resolved

Route 53 record propagation appears to have returned to normal.
Posted May 29, 2025 - 18:24 EDT

Monitoring

We've noticed that some Operations are failing due to Route53 record changes not propagating within the 10 minute time limit allowed by our platform. Running App and Databases are not impacted, but creation or deletion of Databases or Endpoints, as well as scaling services to/from zero containers may be impacted.

We'll continue to monitor the situation and provide updates as we have any additional information to shre.
Posted May 29, 2025 - 18:04 EDT
This incident affected: Aptible Deploy.