us-east-1 Intermittent DNS Resolution Errors

Incident Report for Aptible

Postmortem

Additional detail about timeline: we observed a relative increase in DNS resolver errors in us-east-1 beginning at approximately 2026-03-17 18:30 UTC. The elevated error rate was intermittent rather than constant, with the most visible clusters occurring from roughly 18:30-18:55 UTC and again from about 20:55-21:40 UTC. Error rates returned to normal shortly after 21:40 UTC.

Posted Mar 18, 2026 - 12:50 EDT

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 19:33 EDT

Monitoring

We have observed DNS resolution error rates return to normal levels, and all dependent activities should be functioning normally.

We will continue to monitor for an additional period to ensure the issue is fully resolved before closing the incident. Further updates will be posted here if we observe any recurrence.
Posted Mar 17, 2026 - 19:02 EDT

Investigating

We are currently observing intermittent DNS resolution failures affecting infrastructure in us-east-1. These resolver errors may cause some Aptible Deploy operations (such as deploys, restarts, SSH, or container provisioning) to fail or time out.

Applications running on Aptible Deploy that rely on network hostname resolution may also experience intermittent connection failures related to DNS resolution.

We are actively working with our infrastructure providers to investigate the issue and will provide updates here as they are available.
Posted Mar 17, 2026 - 18:33 EDT
This incident affected: AWS EC2 (AWS EC2 (us-east-1 — Virginia)).