Operations blocked - Route 53 propagation delays
Incident Report for Aptible
Resolved
This incident has been resolved.
Posted Feb 13, 2025 - 19:48 EST
Monitoring
We are noticing Route 53 record requests succeeding in a normal time frame, and are lifting the operation block at this time.

We'll continue to observe running operations to ensure stability.
Posted Feb 13, 2025 - 19:26 EST
Identified
We've noticed that some Operations are failing due to Route53 record changes not propagating within the 10 minute time limit allowed by our platform.

In order to prevent Apps and Databases DNS records from reaching an inconsistent state, we are temporarily blocking Operations.

Performance and reachability of existing Apps and Database is not impacted.
Posted Feb 13, 2025 - 18:51 EST
This incident affected: Aptible Deploy.