Route53 increased propagation delays
Incident Report for Aptible
Resolved
This incident has been resolved.
Posted Mar 03, 2022 - 18:15 EST
Monitoring
At this time we have only observed an impact when creating or destroying DNS records. No DNS record changes have been impacted, so we are resuming normal operations.

Our team will continue to monitor closely, and work to resolve the initially failed operations.
Posted Mar 03, 2022 - 15:27 EST
Identified
We've noticed that some Operations are failing due to Route53 record changes not propagating within the 10 minute time limit allowed by our platform.

In order to prevent Apps and Databases DNS records from reaching an inconsistent state, we are temporarily blocking Operations which will require updating DNS records.
Posted Mar 03, 2022 - 15:06 EST
This incident affected: Aptible Deploy.