CVE-2020-14386 Patching
Incident Report for Aptible
Monitoring
We have completed upgrading the kernel on all App, Bastion and Build instances in shared stacks. We'll continue to update this incident with any further action steps that we plan to take.
Posted Sep 04, 2020 - 11:59 EDT
Update
Between now (11:30am ET) and 12:00pm ET we will be upgrading the kernel on all App, Bastion and Build instances in shared stacks. This will result in brief (< 1 minute) downtime for apps running in shared stacks. We will update this status page when this stage of the upgrade process is complete.
Posted Sep 04, 2020 - 11:30 EDT
Identified
Recently a Linux kernel vulnerability (CVE-2020-14386), which allows for memory corruption and possible privilege escalation, was announced [0].

Our security team began investigating and preparing our remediation strategy yesterday (September 3) at 22:00 UTC. As part of our remediation efforts, we will be restarting all App, Bastion, and Build instances in shared stacks today.

We will update this status page if any further action is required.

[0] https://seclists.org/oss-sec/2020/q3/146
Posted Sep 04, 2020 - 08:50 EDT